Lost data when saving and loading a ws

If we don't know about 'em, we can't fix 'em.

Lost data when saving and loading a ws

PostPosted by ppetro » Sat Jun 24, 2017 3:21 pm

I had a great problem Afater making correcctions in some functions and SAVING the workspace. When I tried to LOAD it again, there were only Functionsn}, )FNS workwed well, but )VARS show nothing, there were no variables. But I coud make a )COPY of the workspace and then apperaed both Functions and Variables.
I were using both the 2 last 64 bit alfa versions with the same results. Whenever I )SAVE AND )LOAD that ws, I apparently lost all VARS, but I can copy them from the same ws. The space most contain some corrupted zone.
An antecedent is thet I were tryng to mark que APL symbols in a new keaboard, and pressed many keys when draing the symbols within theAPL sesssion. I deleted the unwanted displays but when pressed de "1" key, appeared a great many ones and before deleting que lines IT seems that I accidentally entered the long line and the reply was the infinite symbol, and something like "limit error".
I tried to loas previous versions of the ws, but the problem continued, though not in every case. I am trying now to see what is the last correction I made. The data seems to exist in the ws files, since I saw them with a viewing program (without any modification). The ws has some 7 M size and I couldn't form an easier example with that error.
ppetro
 
Posts: 11
Joined: Fri Sep 05, 2014 6:52 pm

Re: Lost data when saving and loading a ws

PostPosted by forummaster » Sat Jun 24, 2017 3:57 pm

So sorry for the trouble.

1. What is the value of ⎕SYSVER from that version?
2. Can you send me the file %APPDATA%\NARS2000\NARS2000.ini ?
3. Can you send me the workspace that when you )LOAD it, )VARS shows no variables?
forummaster
 
Posts: 555
Joined: Wed Jan 23, 2013 1:00 pm

Re: Lost data when saving and loading a ws

PostPosted by ppetro » Sat Jun 24, 2017 9:32 pm

I have just sent the data you asked me, by mail
ppetro
 
Posts: 11
Joined: Fri Sep 05, 2014 6:52 pm

Re: Lost data when saving and loading a ws

PostPosted by ppetro » Tue Jul 11, 2017 5:43 pm

I want to know if there is a form of protected copy, as )PCOPY to copy froms previous workspace data I lost, but not thr existent data.
Is it possible to )COPY only the VARS or de FNS?
Is it posiible a message that or a prohibition of saving from the editor when I make the error of opening it while a program is paused nf forget to close it before saving?
I saw what happens in Dyalog and I was not allowed to save an edition of an executing function.
I made a little function to have the dates of the functions in each ws. includind de save and load.bak, workspaces (⎕NL 3),2 ⎕AT ⎕NL 3)
ppetro
 
Posts: 11
Joined: Fri Sep 05, 2014 6:52 pm

Re: Lost data when saving and loading a ws

PostPosted by forummaster » Thu Jul 20, 2017 4:39 pm

Thanks for all of your hard work helping me isolate this bug. It has been fixed in the latest Alpha release:

http://www.nars2000.org/download/binaries/alpha/

The bug was introduced a few builds ago and was present in two Alpha releases (but not a full release) before the one with the fix which is why so few people were subjected to it.

Thanks again!
forummaster
 
Posts: 555
Joined: Wed Jan 23, 2013 1:00 pm


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 0 guests

cron